Posted on

Meteor 2.7 and the new 2FA package

Introducing the new accounts-2fa package, TailwindCSS 3.x support, and more!

Right after the 2.7 release, we got some feedback from the community, and we have released 2.7.1 already! We have fixed two main issues, an error when using Tailwind CSS on Windows and another one related to the 2FA package when users don’t have an email property in the first level of the user object. You can check their details in the changelog.

Accounts 2FA

We have a new package to announce: accounts-2fa. Now you can have two-factor authentication with the accounts-password and accounts-passwordless .

If you want to provide 2FA for your users, and you are already using accounts-password or accounts-passwordless , you can just go ahead and start using the accounts-2fa functions right away. Otherwise, you don’t need to change your application in any case.

Be sure to check our blog post regarding our 2FA package and also our docs so you can provide 2FA for your users today!

TailwindCSS 3.x

After some improvements in Meteor 2.7, the following minifiers have been updated and tested to support TailwindCSS 3:

juliancwirko:postcss, starting with version 2.1.0standard-minifier-css

If updating from an older version of Tailwind to version 3, please read the TailwindCSS Official migration guide to make sure you had applied the changes required by Tailwind itself.

Support for PostCSS

Starting from version 2.7 of Meteor (and 1.8.0 of standard-minifier-css), Meteor will run PostCSS plugins if you have them configured. If you are using juliancwirko:postcss as your CSS minifier, it is recommended to migrate to standard-minifier-css. For most apps, this will only require switching which minifier the app uses. You can do that using the commands below:

meteor remove juliancwirko:postcss
meteor add standard-minifier-css

There are two differences compared tojuliancwirko:postcss:

The excludedPackages PostCSS option was renamed to excludedMeteorPackagesFiles with the .import.css extension is not treated speciallyNote: In beta.1 of Meteor 2.7 we had added a new core package minifier-css-postcss but later decided to unify everything inside standard-minifier-css. So you shouldn’t use minifier-css-postcss.

Update meteor-node-stubs

As we added support for node: imports, you need to update meteor-node-stubs to its latest version:

meteor npm install [email protected]

Start using Meteor 2.7

As usual, you can run the meteor update –release 2.7 command to start using Meteor 2.7 today. Also, be sure to check our migration guide and the changelog for this version.

Enjoy the new improvements in Meteor, and please let us know your thoughts. Your feedback is always important.

Meteor 2.7 and the new 2FA package was originally published in Meteor Blog on Medium, where people are continuing the conversation by highlighting and responding to this story.

Leave a Reply

Your email address will not be published.