Posted on

Upgrade from 2.3.6 to 2.4.3 ElasticSearch error

I’m trying to upgrade my Magento from 2.3.6 to 2.4.3 and when i start I get this error:

Problem 1
– Can only install one of: elasticsearch/elasticsearch[7.11.x-dev, 6.x-dev].
– Can only install one of: elasticsearch/elasticsearch[7.11.x-dev, 6.5.x-dev].
– Can only install one of: elasticsearch/elasticsearch[7.11.x-dev, 6.7.x-dev].
– Can only install one of: elasticsearch/elasticsearch[7.11.x-dev, 6.8.x-dev].
– Can only install one of: elasticsearch/elasticsearch[7.11.x-dev, 6.x-dev].
– Can only install one of: elasticsearch/elasticsearch[7.11.x-dev, 6.0.x-dev].
– Can only install one of: elasticsearch/elasticsearch[v6.0.0, 7.11.x-dev].
– Can only install one of: elasticsearch/elasticsearch[v6.0.0-beta1, 7.11.x-dev].
– Can only install one of: elasticsearch/elasticsearch[v6.0.1, 7.11.x-dev].
– Can only install one of: elasticsearch/elasticsearch[v6.1.0, 7.11.x-dev].
– Can only install one of: elasticsearch/elasticsearch[v6.5.0, 7.11.x-dev].
– Can only install one of: elasticsearch/elasticsearch[v6.5.1, 7.11.x-dev].
– Can only install one of: elasticsearch/elasticsearch[v6.7.0, 7.11.x-dev].
– Can only install one of: elasticsearch/elasticsearch[v6.7.1, 7.11.x-dev].
– Can only install one of: elasticsearch/elasticsearch[v6.7.2, 7.11.x-dev].
– Can only install one of: elasticsearch/elasticsearch[v6.8.0, 7.11.x-dev].
– Can only install one of: elasticsearch/elasticsearch[v6.8.1, 7.11.x-dev].
– Can only install one of: elasticsearch/elasticsearch[v6.8.2, 7.11.x-dev].
– magento/product-community-edition 2.4.3 requires elasticsearch/elasticsearch ~7.11.0 -> satisfiable by elasticsearch/elasticsearch[7.11.x-dev].
– Installation request for magento/product-community-edition 2.4.3 -> satisfiable by magento/product-community-edition[2.4.3].
– Installation request for elasticsearch/elasticsearch ^6.0 -> satisfiable by elasticsearch/elasticsearch[6.0.x-dev, 6.5.x-dev, 6.7.x-dev, 6.8.x-dev, 6.x-dev, v6.0.0, v6.0.0-beta1, v6.0.1, v6.1.0, v6.5.0, v6.5.1, v6.7.0, v6.7.1, v6.7.2, v6.8.0, v6.8.1, v6.8.2].

We currently have ES version 7.6 and it’s on a cloud server. And as far as I know Magento 2.3.6
ES version 7.6 should be more than enough. Does anyone know why I get this error?

Leave a Reply

Your email address will not be published.